Download Blitzkrieg Mod 4.02b (Patch)

Requires: BK Full v4.0 and Patch v4.02 installed. Please install this hotfix ADDITIONALLY to v4.02!!! This little hotfix fixes the connection problem some users experienced when trying to connect with the Relic Server when starting BK.

Credits: Blitzkrieg-Mod Team

File name File size Downloads Added
blitzkrieg_v4.02_fix.exe 70.2 KB 8 16 Jan 2012

Trending Digital Sales Hunted by Gamehour